Alles over netwerken en security.
 Menu:


 
 Forum  Documentatie
 Forum  Diensten
 Forum  ADSL providers
 CCIE Blog  CCIE BLOG


VPN Server (PPTP) op cisco router

Hoe maak je een van je Cisco router een PPTP VPN server ? Hieronder een voorbeeld configuratie.



Je moet wel over het juiste IOS beschikken, wil je een VPN server draaien.


!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Test-VPN
!
logging buffered 16384 debugging
aaa new-model
!
!
aaa authentication login beheerder local
aaa authentication ppp inbel if-needed local
aaa authorization network default local
aaa session-id common
enable secret cisco
enable password cisco
!
username beheerder password cisco
username vpn password zeergeheim
ip subnet-zero
no ip domain lookup
!
vpdn enable
!
vpdn-group 1
! Default PPTP VPDN group
accept-dialin
protocol pptp
virtual-template 1
!
async-bootp dns-server 212.142.28.66 212.142.28.67
!
!
!
!
interface Loopback0
ip address 172.16.1.254 255.255.255.0
!
interface Ethernet0
ip address 145.219.1.253 255.255.255.0
!
interface Ethernet1
ip address 192.168.1.254 255.255.255.0
!
interface Virtual-Template1
ip unnumbered Loopback0
ip mroute-cache
peer default ip address pool VPN_IPpool
ppp encrypt mppe auto required
ppp authentication ms-chap ms-chap-v2
!
ip local pool VPN_IPpool 172.16.1.1 172.16.1.10
ip classless
ip route 0.0.0.0 0.0.0.0 145.219.1.254
no ip http server
!
!
!
line con 0
exec-timeout 30 0
stopbits 1
line vty 0 4
password cisco
!
scheduler max-task-time 5000
end


IP adressen en wachtwoorden zijn nartuurlijk aan te passen voor eiden gebruik.


2004 - Frizone webdesign